Cannot add feed with single quote [Solved]

Have a question with xFeed, need some help? This is the place.
User avatar
Guest

Cannot add feed with single quote [Solved]

Post by Guest » August 6th, 2009, 2:45 pm

I am also getting this when trying to add a MarketWatch feed.

I tried removing and reinstalling the xFeed App, got the same results.

Checked all the included feeds and it does not appear to be there to me.

http://www.marketwatch.com/rss/newsfind ... ist=sr_rss

I take out the http: as you program has it by default.

Please help!

+anthony

Kevin
Posts: 180
Joined: April 26th, 2009, 6:18 pm
Contact:

Re: Error message that feed exists but can't find it

Post by Kevin » August 10th, 2009, 5:27 pm

Anthony,
It took a second to see what the problem was with this feed. What you did find was a bug. Unfortunately in this version (1.1.1) the "feed exists" message is a catch all error message when there is an problem adding a feed. This will be changed in the next version.

Your particular problem occurs when you are adding a feed with a single quote (') in the url as in "Dvorak's%20Second%20Opinion." This also will be fixed in the next version, however, for the time being you will be able to add this feed by replacing the single quotes with %27.

ie:
marketwatch.com/rss/newsfinder/AllMarketWatchNews/?p=column&pv=John%20Dvorak%27s%20Second%20Opinion&t=John%20Dvorak%27s%20Second%20Opinion&dist=sr_rss

A thousand apologies for this error and a thousand more thank you's for taking the time to post this problem here!

Kevin
Posts: 180
Joined: April 26th, 2009, 6:18 pm
Contact:

Re: Cannot add feed with single quote [Solved]

Post by Kevin » January 4th, 2010, 8:00 pm

This bug has been solved in xFeed 2.0.

Thank you for your input!

Locked