Storage not being released

Found a bug? Report it here
User avatar
Derrick

Storage not being released

Post by Derrick » November 12th, 2014, 2:12 pm

I've noticed that since I've installed 4.2 it seems I keep running out of memory. In my excitement after the upgrade I added a bunch of new feeds in a new category. However I decided to remove the feeds and category later. If I look at manage storage I now am using about 350M of storage. I have 0 unread articles and maybe 50 locked articles. Occasionally the usage goes down a Meg or two but each day it seems to increase.

I'm on iOS 8.0.2.

PS love the new look.

Kevin
Posts: 180
Joined: April 26th, 2009, 6:18 pm
Contact:

Re: Storage not being released

Post by Kevin » November 13th, 2014, 5:51 am

Hello Derrick,

Thanks for sharing and that is an interesting issue. Once a category is removed all data associated with the category ceases to exist and should be reclaimed by the file system. I have been unable to replicate the issue, however, there could be some intricacies that I may be missing.

With that being said, it would likely be very helpful for xFeed to show you how much data it is using and where.
This has been added, additionally there will be an option to clear the web caches (which may be using a substantial amount of space) and also remove cookies.
I'll test it out for a couple days and then get it out there and maybe we can get to the bottom of this...

Thank you for sharing and please do share if you believe I have missed something!

User avatar
Derrick

Re: Storage not being released

Post by Derrick » November 14th, 2014, 4:15 am

I think it may be the cache. I've been monitoring extra closely and just viewing articles then deleting via the trash can inside the feed I've noticed a size able increase in usage. For instance, I read ars technica, wired, slashdot and krebs today, then hit the trash can on each. The usage went from 366 to 382M. No articles were saved.

I look forward to the update.

Kevin
Posts: 180
Joined: April 26th, 2009, 6:18 pm
Contact:

Re: Storage not being released

Post by Kevin » January 16th, 2015, 6:16 pm

Has the storage usage been tamed?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest