xfeed parsing crash? [Open]

Found a bug? Report it here
User avatar
Guest

xfeed parsing crash? [Open]

Post by Guest » September 7th, 2009, 3:02 am

I'm using xFeed to monitor some local craigslist RSS feeds. A few of them cause the status at the top to say "Updating..." then "Parsing..." then xFeed goes away, I'm dropped back to the main iPhone screen. Happens repeatedly.

Here's one of the problem feed URLs:

http://pittsburgh.craigslist.org/evg/index.rss

Kevin
Posts: 180
Joined: April 26th, 2009, 6:18 pm
Contact:

Re: xfeed parsing crash?

Post by Kevin » September 9th, 2009, 2:48 am

Seriously, thank you for posting this problem. :D

I had read some negative comments in the iTunes store about this issue and have been unable to reproduce it, which has been quite annoying. There are so many standards for feeds that are implemented in so many different ways that is quite a challenge to make a reader from scratch that is able to handle all of them without testing every single feed on the internet.

All of the excuses aside, yes, there is a bug when dealing with this feed. Yes, xFeed crashes when in encounters this error. As much as I can tell this stems from an error of xFeed's parser implementation for an RSS .90 feed using the Dublin Core Metadata Element Set. Specifically when it encounters a specific date tag.

Although there is no resolution for the time being, the newest version of xFeed has been tested against this feed and parses properly. Development is making quick strides to a finished product and should be released before too long.

If there are any more feeds which cause xFeed grief, please, post them here so any bugs may be worked out by the next release.

User avatar
Guest

Re: xfeed parsing crash?

Post by Guest » September 10th, 2009, 1:15 am

Thanks for the quick response. As a former coder (parsers included), I feel your pain.

For another test case, this feed also crashes xFeed for me:

http://pittsburgh.craigslist.org/med/index.rss

Looking forward to the next release.

User avatar
Scarbrow

Questionablecontent.net RSS causing parsing error

Post by Scarbrow » September 16th, 2009, 3:20 pm

The site listed in the title is unable to be parsed, despite being detected correctly.

Kevin
Posts: 180
Joined: April 26th, 2009, 6:18 pm
Contact:

Re: xfeed parsing crash?

Post by Kevin » September 17th, 2009, 7:50 pm

Thanks again!

If you come across any more please post them here!

Kevin
Posts: 180
Joined: April 26th, 2009, 6:18 pm
Contact:

Re: xfeed parsing crash? [Solved]

Post by Kevin » January 4th, 2010, 7:46 pm

The parsing algorithm has been updated in xFeed 2.0.

If there are any feeds which still are unable to be parsed, please, share them here.

User avatar
Olivier

Re: xfeed parsing crash? [Open]

Post by Olivier » January 31st, 2010, 10:58 am

Here is a feed that cannot be parsed : http://www.telerama.fr/tag/rss/ma-vie-au-poste.xml
The error message is :

Code: Select all

Error 31 at line 1, Column: 44  

Kevin
Posts: 180
Joined: April 26th, 2009, 6:18 pm
Contact:

Re: xfeed parsing crash? [Open]

Post by Kevin » April 14th, 2010, 12:35 am

** Fixed in xFeed 2.0.1 **

This is an unknown encoding error. The feed from this site is encoded in "windows-1252" for some reason this is causing the parser to crash. The encoding for any feeds encoded with "windows-1252" has been changed to 8859-1. This appears to resolve the issue. Pending any display differences with the small diferences between the encodings, they should display fine. Thank you for sharing.

User avatar
edudant

Re: xfeed parsing crash? [Open]

Post by edudant » May 25th, 2010, 4:42 am

Hi,

I have similar issues with encoding windows-1250:

e.g. http://www.osel.cz/rss/rss.php

Thank you.

Kevin
Posts: 180
Joined: April 26th, 2009, 6:18 pm
Contact:

Re: xfeed parsing crash? [Open]

Post by Kevin » June 10th, 2010, 10:46 pm

Thank you again....
If you post them... they will work

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest